As a Product Manager, I want terms to be displayed a certain way so that it communicates my intent. Instead of "feature", I prefer the "PBI" and "Product Backlog Item". My terms, however, get as "Pbi" and "Product backlog item", respectively. I think that if we are customizing the terms, then they should be taken at face value with the exception of pluralizing, such as "PBIs" and "Product Backlog Items", where applicable.
|Release time frame|